Announcement

Collapse
No announcement yet.

FT4 Contacts not downloading from LOTW

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FT4 Contacts not downloading from LOTW

    I have made many FT4 contacts and after updating TQSL to the latest version 2.4.7, I uploaded all my FT4 contacts. I checked LOTW and it shows the confirmed contacts that I have made. When I went to download the latest confirmed contacts to my logbook it started to download 175 contacts but did not finish and I clicked on finish and the process ended. But when I checked my logbook for confirmation, none of my contacts where indicating confirmation on LOTW. I tried to download again but it showed only 2 contacts to download. How can I get my confirmations to show up in my logbook?
    Thanks, Tom K9VER

  • #2
    Unfortunately, HRD Logbook doe not support the ADIF submode designation which is where FT4 resides. Hopefully, HRD will fix this in the future.
    For now, what I do is:
    1) Filter your FT4 QSOs in HRD logbook.
    2) Bulk edit all FT4 QSO changing the mode to MFSK
    3} Download LoTW, backdating the starting date to when you first started logging FT4 QSOs
    4} All your LoTW FT4 QSLs will mark your MFSK QSOs as Verified.
    5) Filter your MFSK QSOs in HRD logbook
    6) Bulk edit the MFSK QSOs changing the mode to FT4.

    Obviously, if you have any real MFSK QSOs, you must be careful not to inadvertently alter them.

    Semi-painful process until HRD Logbook is fixed to recognize ADIF submodes.
    73, Jim - N4ST
    __________________________________________________ __
    3GHz Core 2 Duo, 8GB, Win10 64-bit, TASCAM US-322, FTDI, Ten-Tec Omni VII, HRD 6.2.3.410

    Comment


    • #3
      I called HRD Customer Support yesterday and talked to Kevin about this problem. He said I needed to use the HRD Logbook "Modes Editor" to add or edit Mode = FT4 & ADIF = MFSK.
      (Open HRD Logbook > Configure > Modes Editor > Add a new FT4 mode entry or Edit an existing FT4 mode entry so that Mode FT4 = ADIF MFSK)
      Then I needed to configure TQSL to map FT4 to MFSK ( Open TQSL > File > Display or Modify Preferences > Click on the ADIF Modes tab > Click on the Add button > Scroll down to and select FT4 > Enter MSFK in the ADIF box > Click on Save)
      After making these changes, I opened HRD Logbook, clicked on the Mode column header to consolidate all of my FT4 contacts, selected all of my FT4 contacts and re-uploaded all 354 of them to LoTW. The logbook immediately displayed many of these entries as Verified (Match) in the LoTW Received column. I can now download data from LoTW without getting a bunch of "no match for xxxxx" errors for the FT4 contacts. These changes seem to be working and have had no negative affect on my eQSL uploads or downloads.
      I asked Kevin if HRD Logbook would be upgraded to be fully ADIF 3.1.0 compliant with a column for Submode. He said he didn't know if or when that would happen.
      Not an ideal solution, but this seems to be working OK for me.

      73 de Gary - AC6EG

      Comment


      • #4
        Originally posted by AC6EG View Post
        I called HRD Customer Support yesterday and talked to Kevin about this problem. He said I needed to use the HRD Logbook "Modes Editor" to add or edit Mode = FT4 & ADIF = MFSK.
        (Open HRD Logbook > Configure > Modes Editor > Add a new FT4 mode entry or Edit an existing FT4 mode entry so that Mode FT4 = ADIF MFSK)
        Then I needed to configure TQSL to map FT4 to MFSK ( Open TQSL > File > Display or Modify Preferences > Click on the ADIF Modes tab > Click on the Add button > Scroll down to and select FT4 > Enter MSFK in the ADIF box > Click on Save)
        After making these changes, I opened HRD Logbook, clicked on the Mode column header to consolidate all of my FT4 contacts, selected all of my FT4 contacts and re-uploaded all 354 of them to LoTW. The logbook immediately displayed many of these entries as Verified (Match) in the LoTW Received column. I can now download data from LoTW without getting a bunch of "no match for xxxxx" errors for the FT4 contacts. These changes seem to be working and have had no negative affect on my eQSL uploads or downloads.
        I asked Kevin if HRD Logbook would be upgraded to be fully ADIF 3.1.0 compliant with a column for Submode. He said he didn't know if or when that would happen.
        Not an ideal solution, but this seems to be working OK for me.

        73 de Gary - AC6EG
        This approach was documented earlier in this thread and is a good workaround IF FT4 is the only submode of MFSK that you want to upload. If you also want to upload another submode of MFSK such as JS8 then you are out of luck. Submodes have been in the ADIF spec for at least 5 years. HRD needs to get with the program and get this fixed with the next release.

        73, Charlie - K0LAF
        73,
        Charlie, KØLAF

        Comment


        • #5
          Ok I must be doing some thin wrong.. Followed the steps above and still not updating...
          When I look at the downloaded LOTW file it shows MODE = DATA and they dont match up in the log.

          Maybe just me...

          Comment


          • #6
            Once you have mapped FT4 to MFSK in both HRD Logbook and TQSL, you have to re-upload all your FT4 contacts to LoTW. Everything should then match as MODE=MFSK.
            This is just a temporary fix until HRD makes the logbook compliant with ADIF 3.1.0. (Don't do this if your logbook contains actual MFSK mode QSO's)
            The most recent issue of the HRD Newsletter included the following statement from Mike, VK4/WA9PIE:
            While we're proceeding with beta testing for this release, I've asked the team to look at the issue related to matching FT4 confirmations from LOTW in HRD Logbook
            73 de Gary - AC6EG

            Comment


            • #7
              The test of any fix or work around is do FT4 contacts show as FT4 in LOTW (just like all the other modes FT8, PSK31, CW etc.) .... If it shows as MFSK or Data in LOTW or HRD, then it is useless for awards such as WAS and general record keeping ...

              And it really doesn't matter what HRD shows ... The only place it matters is what's in LOTW ...

              Below was posted in Mantis by another user who understands the problem:

              "By repeatedly giving incorrect information and urging users to map
              FT4 > DATA your support staff are certainly hurting both users and
              LotW.

              <snip> ...study (log/export a couple FT4 QSOs and study the
              tQSL config.xml file) to determine that the proper short term work-
              around would be to "map" FT4 -> FT4 just as you "map" MFSK8 -> MFSK8
              and MFSK16 -> MFSK16. That will result in FT4 QSOs being uploaded
              to LotW at FT4 and LotW QSLs will "verify".


              Which means: Mode=FT4 ADIF=FT4

              With the MFSK8 and MFSK16 examples right in front of them, it should
              be a simple matter for your support staff to give your users the
              correct answer rather than screw things up with manifestly incorrect
              information.

              *NOTHING* will fix the problem when users upload FT4 as either
              <MODE:4> MFSK or <MODE4:> DATA. That QSO data will not "match"
              QSO data with FT4 for WAS and will only be accepted for DXCC,
              WAZ and WPX (and VUCC which does not care about mode)."
              Last edited by W3RJW; 09-04-19, 15:22.
              Ron, W3RJW

              HRD v6.6.0.236
              Acer Aspire XC600, Intel Pentium Dual Core 2.9GHz, 8 GB Memory, 64-bit OS, Windows 8.1,
              Access Data Base
              FTdx-5000+Timewave Navigator Interface/FTdx-3000+SignaLink USB Interface, .. WSJT-X v2.1.0, JTAlertX v2.14.4, HRD v6.6.0.236

              Comment

              Working...
              X