Announcement

Collapse
No announcement yet.

Rig control starts up trying to connect to wrong com port !!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rig control starts up trying to connect to wrong com port !!

    Rig control starts up trying to connect to wrong com port and I must wait for three time outs to change the com port to the correct one and connect. I DO set the default but it is not saved and the process repeats until I can manually choose correct port. HRD starts up again on wrong por. This has happened for the last several upgrades. Included, please see .xml file for Connecting to port. I
    have to uncheck "Always connect" and set proper port every time I start HRD up. It did used to work properly Jim WB8EYE (Long time user)

    On my list of com ports I have com1 and com10. Rigcontrol seems to sort com10 prior to com1 and selects this as the default port to use. I renamed com10 to com9 and rig control behaves properly again. Com10 is used for rotator but will of course work as Com9. One could check the sorting algorithm in rig control task.

    Jim... again
    Attached Files
    Last edited by WB8EYE; 03-10-19, 21:34. Reason: Discovered this....

  • #2
    What is the correct info that it should connect to? If the attached file is correct what does HRD try to connect to? Lastly, have you tried deleting your entry in the connect to box and re-install it?

    Comment


    • #3
      Same problem here since the latest update.
      Yes I tried deleting the existing radio entry and recreating it anew.

      Same problem.

      Correct settings:
      Kenwood TS-2000
      Com 1
      57,600

      When it first starts the screen shows the correct setup
      Upon clicking on CONNECT the com port changes to Com 12

      Wait for 3 tries
      Change the com port back to Com1
      Upon clicking CONNECT the speed changes to 115,200

      Wait for 3 tries
      Change the speed back to 57.600 (Make sure the com port is still Com1)

      Now it works (Until next time).

      Repeats every time.
      Never did this before.

      Current version V6.0.5.199

      Comment


      • #4
        Hmmm, you have me stumped. Does it consistently switch to Com12? If so you might go into device manager and then Properties on Com1. Port Settings tab and click on advanced. Change the comport to Com12 and reboot. See if it will connect to Com12 after reboot and report back. If not hopefully you have support and can open a ticket. Or maybe some other ham has the same problem and can open a ticket if my advice doesn't work. I've been in computers since the 70's and retired from IT support at a major company.

        Comment


        • #5
          A long shot but it is possible that the file now has read only properties which is why you cannot save the settings.
          The file is here. C:\Users\******\AppData\Roaming\HRDLLC\Ham Radio Deluxe/HRDConnectSettings.xml
          HTH
          Icom ic-7610, SPE 1K-FA amp,Hex beam, Butternut HF6V and homebrew 40m/60m/80m trap dipole.
          PC - Windows 10.
          Intel 4 Core i5-4460 CPU@3.2GHz, 8GB RAM,

          Comment


          • #6
            I've opened a support ticket.

            Lets see what they can come up with.

            "Com port keeps changing #984858"

            John
            KW7A

            Comment


            • #7
              Just a thought....

              Are you sing a native 9 pin RS-232 connection (IE not a USB/RS-232 adapter) ???

              Mine is a native 9 pin RS-232 port.

              I wonder if that makes a difference.

              Comment


              • #8
                FIXED ! ! ! ! ! !
                I just got a call back from Ham Radio Deluxe, Support.

                He connected into my computer and did a look see.

                Bottom line ---

                We are not sure exactly what fixed the problem but the last thing he tried wad deleting my virtual COMM ports, (I said it was OK and I could add them back in latter). Then he had me unplug and re-connect my RS-232 cable to my radio.

                Low and behold, everything is working now.

                I hope this may help you also.

                John
                KW7A
                Nephi, Utah

                Comment

                Working...
                X